$re = '/(?<!__num)(?<!\d)110(?!\d)/m';
$str = 'can there be B110 numbers and 10 numbers in this sentence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);