re = /(?<!__num)(?<!\d)110(?!\d)/m
str = 'can there be B110 numbers and 10 numbers in this sentence'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end