package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w-]+)\..*$`)
var str = `../dir1/dir2/dir3/filename.tar.gz
../dir1/dir2/dir3/filename.tar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}