$re = '/([\w-]+)\..*$/m';
$str = '../dir1/dir2/dir3/filename.tar.gz
../dir1/dir2/dir3/filename.tar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);