using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{\s*\""[^""]+\""\s*(,)\s*\""[^""]+\""\s*}";
string input = @"{""key1"":""val1"", ""key2"": { ""val2-1"" , ""val2-2""}, ""key3"": {""val3-1"",""val3-2""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}