// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m){\s*\"[^"]+\"\s*(,)\s*\"[^"]+\"\s*}"#).unwrap();
let string = "{\"key1\":\"val1\", \"key2\": { \"val2-1\" , \"val2-2\"}, \"key3\": {\"val3-1\",\"val3-2\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}