import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\S)\\h{2,}(?=\\S)";
final String string = " <Directory \"THEDIRECTORY\">\n"
+ " <LimitExcept GET POST>\n"
+ " deny from all\n"
+ " </LimitExcept>\n"
+ " Options -Indexes -MultiViews\n"
+ " AllowOverride All\n"
+ " Order allow,deny\n"
+ " Allow from all\n"
+ " </Directory>";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}