re = /(?<=\S)\h{2,}(?=\S)/m
str = ' <Directory "THEDIRECTORY">
<LimitExcept GET POST>
deny from all
</LimitExcept>
Options -Indexes -MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result