re = /^(?!.*(?:\h+\d+){2})[689](?:\h*\d){7}$/m
str = '61234567
6123 4567
6123 4567
6123 456 7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end