$re = '/^((?:https?:)?\/\/)?((?:www|m)\.)?((?:aparat(-nocookie)?\.com))(\/(?:[\w\-]+\?v=|embed\/|v\/)?)([\w\-]+)(\S+)?$/mi';
$str = 'http://www.aparat.com/v/bqn5H
http://aparat.com/v/bqn5H
https://www.aparat.com/v/bqn5H
https://aparat.com/v/bqn5H';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);