re = /^((?:https?:)?\/\/)?((?:www|m)\.)?((?:aparat(-nocookie)?\.com))(\/(?:[\w\-]+\?v=|embed\/|v\/)?)([\w\-]+)(\S+)?$/mi
str = 'http://www.aparat.com/v/bqn5H
http://aparat.com/v/bqn5H
https://www.aparat.com/v/bqn5H
https://aparat.com/v/bqn5H'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end