import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?\\(?([0-9]{2,4})[)\\s.-]+([0-9]{3,4})([\\s.-]+([0-9]{3,4}))?$";
final String string = "(94) 123 345\n"
+ "(94).456.7899\n"
+ "(94)-456-7899\n"
+ "94-456-7899\n"
+ "+94 456 7899\n"
+ "94 456 7899\n"
+ "0094 456 7899\n"
+ "(94) 123\n"
+ "122 3454";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}