$re = '/\d+(?:\s+[A-Za-z.]+)+/m';
$str = 'Suite 400 - 100 ABCDEF
5 ABC Bay SW.
1 123 Abc Street';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);