// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(?:\s+[A-Za-z.]+)+").unwrap();
let string = "Suite 400 - 100 ABCDEF
5 ABC Bay SW.
1 123 Abc Street";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}