#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((http|https)://)?(www)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,9}\b([-a-zA-Z0-9()@:%_\|+.~#?&//={};,\[\]'"$\x60]*)?"
Local $sString = "http://127.0.0.1/" & @CRLF & _
"http://127.0.0.1" & @CRLF & _
"http://www.127.0.0.1/m=weblogin/loginform238,363,771,89816356,2167" & @CRLF & _
"127.0.0.1:8080" & @CRLF & _
"127.0.0.1" & @CRLF & _
"google.com" & @CRLF & _
"google.com:80" & @CRLF & _
"www.google.com" & @CRLF & _
"https://google.com" & @CRLF & _
"https://www.google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")