import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http|https)://)?(www)?[-a-zA-Z0-9@:%._\\+~#=]{1,256}\\.[a-zA-Z0-9()]{1,9}\\b([-a-zA-Z0-9()@:%_\\|+.~#?&//=\\{\\};,\\[\\]'\"$\\x60]*)?";
final String string = "http://127.0.0.1/\n"
+ "http://127.0.0.1\n"
+ "http://www.127.0.0.1/m=weblogin/loginform238,363,771,89816356,2167\n"
+ "127.0.0.1:8080\n"
+ "127.0.0.1\n"
+ "google.com\n"
+ "google.com:80\n"
+ "www.google.com\n"
+ "https://google.com\n"
+ "https://www.google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}