package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@(\w+)`)
var str = `From @victor with love,
To @andrea,
and CC goes to @ghost`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}