$re = '/@(\w+)/m';
$str = 'From @victor with love,
To @andrea,
and CC goes to @ghost';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);