$re = '/(?:^|,)(?=[^"]|(")?)"?((?(1)(?:[^"]|"")*|[^,"]*))"?(?=,|$)/mx';
$str = ',2.99,AMO024,Title,"Description, more info",,123987564
123,2.99,AMO024,Title,"Description, more info",,123987564
"""test"" test","test""fdas""fdad",
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);