import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p class=\"text_obisnuit\">(?:(?!<\\/p>)(?!<p).)*(?:\\R|\\z)";
final String string = "<p class=\"text_obisnuit\"><em>I have to make sure of that</em></p>\n\n"
+ "<p class=\"text_obisnuit\"><em>I have to make sure of that</em><br>\n"
+ "<p class=\"text_obisnuit\">I have to make sure of that</div>\n"
+ "<p class=\"text_obisnuit\">I have to make sure of that\n"
+ "</div>\n\n"
+ "<p class=\"text_obisnuit\"><em>I have to make sure of that</em>\n"
+ "</p>\n\n"
+ "Toto, regex it should also not select the last line. I forgot to write it in my last update :)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}