$re = '/<p class="text_obisnuit">(?:(?!<\/p>)(?!<p).)*(?:\R|\z)/m';
$str = '<p class="text_obisnuit"><em>I have to make sure of that</em></p>
<p class="text_obisnuit"><em>I have to make sure of that</em><br>
<p class="text_obisnuit">I have to make sure of that</div>
<p class="text_obisnuit">I have to make sure of that
</div>
<p class="text_obisnuit"><em>I have to make sure of that</em>
</p>
Toto, regex it should also not select the last line. I forgot to write it in my last update :)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);