package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(^\$\w+)|[^\\](\$\w+))`)
var str = `$10<i class="">$i01d</i>\$id$id
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}