$re = '/(?:(^\$\w+)|[^\\\\](\$\w+))/';
$str = '$10<i class="">$i01d</i>\\$id$id
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);