import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|([1-9]+)\\|(UpdatePanel)\\|(updatePanel1|updatePanel2)\\|([^|]*)";
final String string = "|255|UpdatePanel|updatePanel1|somecontent1234|\n"
+ "|255|UpdatePanel|updatePanel1|somecontent1234|256|UpdatePanel|updatePanel2|someOtherContent|";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}