$re = '/\|([1-9]+)\|(UpdatePanel)\|(updatePanel1|updatePanel2)\|([^|]*)/';
$str = '|255|UpdatePanel|updatePanel1|somecontent1234|
|255|UpdatePanel|updatePanel1|somecontent1234|256|UpdatePanel|updatePanel2|someOtherContent|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);