#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<timestamp>.{15}) (?<host>[^ ]*) (?<seqno>[^ ]*) (?<ignore>[^%]*) (?<log_type>[^:]*): (?<message>.*)"
Local $sString = "Jan 31 23:59:58 192.168.3.121 1246088: Jan 31 23:59:57: %SEC-6-IPACCESSLOGP: list VTYACCESS denied tcp 59.1.188.127(2159) -> 0.0.0.0(23), 1 packet"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")