re = /(?<timestamp>.{15}) (?<host>[^ ]*) (?<seqno>[^ ]*) (?<ignore>[^%]*) (?<log_type>[^:]*): (?<message>.*)/
str = 'Jan 31 23:59:58 192.168.3.121 1246088: Jan 31 23:59:57: %SEC-6-IPACCESSLOGP: list VTYACCESS denied tcp 59.1.188.127(2159) -> 0.0.0.0(23), 1 packet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end