use strict;
my $str = '12345678901234
123456789012345
1234567890123456
12345678901234567';
my $regex = qr/^[0-9]{15}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";