$re = '/^[0-9]{15}$/m';
$str = '12345678901234
123456789012345
1234567890123456
12345678901234567';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;