const regex = /(?:(?:www.|http::?\/\/)?example\.com\/)+(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:www.|http::?\\\/\\\/)?example\\.com\\\/)+(.*)', '')
const str = `www.example.com/example.com/http:://example.com/www.abc.com/xyz.com/example.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}