$re = '/(?:(?:www.|http::?\/\/)?example\.com\/)+(.*)/';
$str = 'www.example.com/example.com/http:://example.com/www.abc.com/xyz.com/example.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);