$re = '/(\.\.\/)(?=fonts\/bootstrap)/';
$str = '../fonts/bootstrap/glyphicons-halflings-regular.eot
../fonts/bootstrap/glyphicons-halflings-regular.eot
../dave
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);