re = /(\.\.\/)(?=fonts\/bootstrap)/
str = '../fonts/bootstrap/glyphicons-halflings-regular.eot
../fonts/bootstrap/glyphicons-halflings-regular.eot
../dave
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end