import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\s)(?<!since)\\s*1\\.0\\.0";
final String string = "/**\n"
+ " * @since 1.0.0 <--- this shouldn't be matched\n"
+ " * @package blah blah blah\n"
+ " * Version: 1.0.0 <--- this should be matched\n"
+ " */\n\n"
+ "/**\n"
+ " * Fired during plugin activation.\n"
+ " *\n"
+ " * This class defines all code necessary to run during the plugin's activation.\n"
+ " *\n"
+ " * @since 1.0.0 <--- this shouldn't be matched\n"
+ " * @package blah blah\n"
+ " * @subpackage blah blah\n"
+ " * @author blah blah\n"
+ " */\n\n"
+ "define( 'PLUGIN_VERSION', '1.0.0' ); // <--- this should be matched\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}