use strict;
my $str = '/**
* @since 1.0.0 <--- this shouldn\'t be matched
* @package blah blah blah
* Version: 1.0.0 <--- this should be matched
*/
/**
* Fired during plugin activation.
*
* This class defines all code necessary to run during the plugin\'s activation.
*
* @since 1.0.0 <--- this shouldn\'t be matched
* @package blah blah
* @subpackage blah blah
* @author blah blah
*/
define( \'PLUGIN_VERSION\', \'1.0.0\' ); // <--- this should be matched
';
my $regex = qr/(?<!\s)(?<!since)\s*1\.0\.0/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}