re = /^(\d{1,3})\s*([FM])\s*\.?(\w+)\s*\.?(\w+)\s*\.?(\w+\.\w+|\w+)\s*$/m
str = '95F Front Anger BW
95F Front Anger BW
95F Front Anger.BW
95F.Front.Anger.C.Micro
95F.Front.Fear.C.Micro
95F.Front.Frown.BW'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end