package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<slug>[a-zA-Z0-9-]+)\/(?P<tom>[a-zA-Z0-9-]+)`)
var str = `1000/fnord
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}