$re = '/(?P<slug>[a-zA-Z0-9-]+)\/(?P<tom>[a-zA-Z0-9-]+)/m';
$str = '1000/fnord
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);