re = /(?<!\)),/
str = '(40.959953710949506, -74.18210638344726),(40.95891663745299, -74.10606039345703),(40.917472246121065, -74.09582940498359),(40.921752754230255, -74.16397897163398),(40.95248644043785, -74.21067086616523)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end