package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Zа-яА-Я]+)([0-9]+)`)
var str = `Сообщения21
Статьи345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}