$re = '/([a-zA-Zа-яА-Я]+)([0-9]+)/m';
$str = 'Сообщения21
Статьи345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);