package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9\.,\-]+)\s?(car\b|cars\b|cars\w+)`)
var str = `i have 2 cars and 2cars`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}