// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)([0-9\.,\-]+)\s?(car\b|cars\b|cars\w+)").unwrap();
let string = "i have 2 cars and 2cars";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}