#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\[(\d+)\].*$"
Local $sString = "carousels['components'][0][0][title]" & @CRLF & _
"carousels['components'][0][1][title]" & @CRLF & _
"carousels['components'][0][2][title]" & @CRLF & _
"" & @CRLF & _
"carousels['components'][1][0][title]" & @CRLF & _
"carousels['components'][1][1][title]" & @CRLF & _
"carousels['components'][1][2][title]" & @CRLF & _
"" & @CRLF & _
"carousels['components'][2][0][title]" & @CRLF & _
"carousels['components'][2][1][title]" & @CRLF & _
"carousels['components'][2][2][title]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")