$re = '/^.*\[(\d+)\].*$/m';
$str = 'carousels[\'components\'][0][0][title]
carousels[\'components\'][0][1][title]
carousels[\'components\'][0][2][title]
carousels[\'components\'][1][0][title]
carousels[\'components\'][1][1][title]
carousels[\'components\'][1][2][title]
carousels[\'components\'][2][0][title]
carousels[\'components\'][2][1][title]
carousels[\'components\'][2][2][title]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);