import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "top[\\W_]*+b[\\W_]*+school[\\W_]*+admission(?!\\.in(?<=topbschooladmission\\.in))";
final String string = "The “Top B School Admission” is most trusted consultancy in India that offer you the direct admissions for the courses\n"
+ "We provide the best admission consultancy services in India for taking online admissions in MBA, BBA, BCom awarded by many institutions & universities across the country. Simply request a callback. We are India& best Online Admission Counselors. Call us today ! \n"
+ "We have a tieup with top colleges & universities as well as with Deemed universities. So get this opportunities\n\n"
+ "We provide the courses admission in top institutes like :\n"
+ "SIBM\n"
+ "MIT-WPU\n"
+ "Bharti vidhyapeeth\n"
+ "Welingkar\n"
+ "D. Y. Patil etc.\n"
+ "The direct admissions are open for AY 2021. So hurry up & book your seat with us. \n"
+ "For more details get back to us on :\n"
+ "Phone : 9921499691\n"
+ "You can also write to us on: info@topbschooladmission.in\n"
+ "[enter link description here][1]\n\n\n"
+ " [1]: https://www.topbschooladmission.in/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}