#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z0-9]*_ECOLI)\n([A-Z\n]*)"
Local $sString = ">YBGC_ECOLI" & @CRLF & _
"MNTTLFRWPVRVYYEDTDAGGVVYHASYVAFYERARTEMLRHHHFSQQALMAERVAFVVRKMTVEYYAPA" & @CRLF & _
"RLDDMLEIQTEITSMRGTSLVFTQRIVNAENTLLNEAEVLVVCVDPLKMKPRALPKSIVAEFKQ" & @CRLF & _
">USHA_ECOLI" & @CRLF & _
"MKLLQRGVALALLTTFTLASETALAYEQDKTYKITVLHTNDHHGHFWRNEYGEYGLAAQKTLVDGIRKEV" & @CRLF & _
"AAEGGSVLLLSGGDINTGVPESDLQDAEPDFRGMNLVGYDAMAIGNHEFDNPLTVLRQQEKWAKFPLLSA" & @CRLF & _
"NIYQKSTGERLFKPWALFKRQDLKIAVIGLTTDDTAKIGNPEYFTDIEFRKPADEAKLVIQELQQTEKPD" & @CRLF & _
"IIIAATHMGHYDNGEHGSNAPGDVEMARALPAGSLAMIVGGHSQDPVCMAAENKKQVDYVPGTPCKPDQQ" & @CRLF & _
"NGIWIVQAHEWGKYVGRADFEFRNGEMKMVNYQLIPVNLKKKVTWEDGKSERVLYTPEIAENQQMISLLS" & @CRLF & _
"PFQNKGKAQLEVKIGETNGRLEGDRDKVRFVQTNMGRLILAAQMDRTGADFAVMSGGGIRDSIEAGDISY" & @CRLF & _
"KNVLKVQPFGNVVVYADMTGKEVIDYLTAVAQMKPDSGAYPQFANVSFVAKDGKLNDLKIKGEPVDPAKT" & @CRLF & _
"YRMATLNFNATGGDGYPRLDNKPGYVNTGFIDAEVLKAYIQKSSPLDVSVYEPKGEVSWQ" & @CRLF & _
">CN16_ECOLI" & @CRLF & _
"MIKFSATLLATLIAASVNAATVDLRIMETTDLHSNMMDFDYYKDTATEKFGLVRTASLINDARNEVKNSV" & @CRLF & _
"LVDNGDLIQGSPLADYMSAKGLKAGDIHPVYKALNTLDYTVGTLGNHEFNYGLDYLKNALAGAKFPYVNA" & @CRLF & _
"NVIDARTKQPMFTPYLIKDTEVVDKDGKKQTLKIGYIGVVPPQIMGWDKANLSGKVTVNDITETVRKYVP" & @CRLF & _
"EMREKGADVVVVLAHSGLSADPYKVMAENSVYYLSEIPGVNAIMFGHAHAVFPGKDFADIEGADIAKGTL" & @CRLF & _
"NGVPAVMPGMWGDHLGVVDLQLSNDSGKWQVTQAKAEARPIYDIANKKSLAAEDSKLVETLKADHDATRQ" & @CRLF & _
"FVSKPIGKSADNMYSYLALVQDDPTVQVVNNAQKAYVEHYIQGDPDLAKLPVLSAAAPFKVGGRKNDPAS" & @CRLF & _
"YVEVEKGQLTFRNAADLYLYPNTLIVVKASGKEVKEWLECSAGQFNQIDPNSTKPQSLINWDGFRTYNFD" & @CRLF & _
"VIDGVNYQIDVTQPARYDGECQMINANAERIKNLTFNGKPIDPNAMFLVATNNYRAYGGKFAGTGDSHIA" & @CRLF & _
"FASPDENRSVLAAWIADESKRAGEIHPAADNNWRLAPIAGDKKLDIRFETSPSDKAAAFIKEKGQYPMNK" & @CRLF & _
"VATDDIGFAIYQVDLSK" & @CRLF & _
">6PGD_ECOLI" & @CRLF & _
"MSKQQIGVVGMAVMGRNLALNIESRGYTVSIFNRSREKTEEVIAENPGKKLVPYYTVKEFVESLETPRRI" & @CRLF & _
"LLMVKAGAGTDAAIDSLKPYLDKGDIIIDGGNTFFQDTIRRNRELSAEGFNFIGTGVSGGEEGALKGPSI" & @CRLF & _
"MPGGQKEAYELVAPILTKIAAVAEDGEPCVTYIGADGAGHYVKMVHNGIEYGDMQLIAEAYSLLKGGLNL" & @CRLF & _
"TNEELAQTFTEWNNGELSSYLIDITKDIFTKKDEDGNYLVDVILDEAANKGTGKWTSQSALDLGEPLSLI" & @CRLF & _
"TESVFARYISSLKDQRVAASKVLSGPQAQPAGDKAEFIEKVRRALYLGKIVSYAQGFSQLRAASEEYNWD" & @CRLF & _
"LNYGEIAKIFRAGCIIRAQFLQKITDAYAENPQIANLLLAPYFKQIADDYQQALRDVVAYAVQNGIPVPT" & @CRLF & _
"FSAAVAYYDSYRAAVLPANLIQAQRDYFGAHTYKRIDKEGVFHTEWLD" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")