using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[!#%&\'*+,\-./:;<=>?@\\\^_\`|~](?!\w)|[\""\)\(\]\[{}]|[^\s]*?(?=[!\""#%&\'()*+,\-./:;<=>?@[\\\]^_\`{|}~]?(?:\s|$))";
string input = @"If you (didn't) cry, I [will] give you sweets. Then I will give you home-made cakes.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}