$re = '/[!#%&\'*+,\-./:;<=>?@\\\\\^_\`|~](?!\w)|[\"\)\(\]\[{}]|[^\s]*?(?=[!\"#%&\'()*+,\-./:;<=>?@[\\\\\]^_\`{|}~]?(?:\s|$))/';
$str = 'If you (didn\'t) cry, I [will] give you sweets. Then I will give you home-made cakes.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);