#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ui)^[a-zàáâäæçèéêëìíîïñòóôœùúûüýÿß](?:[ -][a-z]|['a-zàáâäæçè éêëìíîïñòóôœùúûüýÿß]+)+$"
Local $sString = "abcdef-abcdef1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")